test email

Have a suggestion for a new feature? Voice your thoughts here.

test email

Postby WitteGeek402 » Sat Jul 06, 2013 9:09 pm

Hi. I'm having a problem getting my email settings correct with gmail. I know that supposedly I can send an email with the aspmx.l.google.com stmp site, but I'm not having any luck. A 'send test email' button would really be helpful on the 'system settings' page. Unless there is a better way to do this. Always open to other ideas.
WitteGeek402
 
Posts: 36
Joined: Sun Jun 09, 2013 11:46 am
HydroFLASH Type: HydroFLASH Wired Version
Mobile App Type: Android
Insteon Devices: Yes

Re: test email

Postby Support » Sat Jul 06, 2013 9:26 pm

Hi,

Gmail requires TLS which is not supported (currently) by HydroFLASH. We recommend using your primary ISP's SMTP server and your local credentials. The supported email authentication types are listed in the user manual. When changing any of the settings related to email on the settings page, a test email is sent.

As an example Cox ISP is shown below: (from settings page)
Email SMTP Server Name: smtp.west.cox.net Port: 587
Email Login User Name: john.doe Password: *********
Email Address (To send log files to): john.doe@cox.net (This can be your gmail address, etc)

We are looking to add in TLS/SSL support at some point in the future.
Brooks
HydroFLASH Support
Support
 
Posts: 319
Joined: Sat Mar 02, 2013 4:46 pm
HydroFLASH Type: HydroFLASH WiFi Version
Mobile App Type: Both
Insteon Devices: Yes

Re: test email

Postby WitteGeek402 » Sun Jul 07, 2013 2:41 am

Thank you. I did exactly that. I appreciate your prompt response.
WitteGeek402
 
Posts: 36
Joined: Sun Jun 09, 2013 11:46 am
HydroFLASH Type: HydroFLASH Wired Version
Mobile App Type: Android
Insteon Devices: Yes

Re: test email

Postby ExploreUtah » Fri Aug 02, 2013 4:09 am

I'm having the same problems configuring the email. I believe I have followed the instructions to the letter but no Test emails are being sent through my ISP. Have you had anyone else had issues with using Comcast ?

Settings used:
Email SMTP Server Name: smtp.comcast.net
Port: 465 (per Comcast recommended setting - Have also tried 587 since SSL is not required with no luck)

Email Login User Name: have set this correctly
Email Address (To send log files to): have set this to email address

Comcast email client reference URL: http://customer.comcast.com/help-and-su ... ity-email/

Any help is appreciated.
ExploreUtah
 
Posts: 2
Joined: Tue Jul 30, 2013 1:23 am
HydroFLASH Type: ----
Mobile App Type: ----
Insteon Devices: ----

Re: test email

Postby WitteGeek402 » Fri Aug 02, 2013 4:23 pm

Hey. I did a quick search and using the outlook 2010 as a guideline http://forums.comcast.com/t5/E-Mail-and-Xfinity-Connect-Help/E-Mail-Client-Settings-customer-generated/td-p/778889 on what you might need to do I have 2 guesses the first easy.

Did you put in your password? ::crossing fingers for you::

Another possibility from the same page says Comcast may require an SSL which is the same as the google problem. I made the font big below where it says that.

------------------------------------------------------------------------------------------------------------------------
Windows Mail, Windows Live Mail, Outlook Express & Outlook 2000:
choose Tools
choose Accounts
go to the Mail tab
click on your Comcast account to highlight it
choose Properties
go to the General tab
under Mail Account, enter whatever you'd like to call this account, like John Doe on Comcast
under User Information, enter Name (whatever you want to appear on your messages)
enter E-mail address (your full Comcast email address)
check "Include this account when receiving mail or synchronizing"
go to the Servers tab
"My incoming mail server is a" POP3 "server"
Incoming mail is mail.comcast.net
Outgoing mail is smtp.comcast.net
enter your Account name or Email user name (your Comcast user ID, the part before "@comcast.net" in your email address)
enter your Password
check "Remember password"
make sure “Logon using Secure Password Authentication (SPA)” is NOT checked
check “My server requires authentication”
choose Settings
choose “Use same settings as my incoming mail server”
click OK
go to the Advanced tab
check both boxes for “This server requires a secure connection (SSL)”
change port number to 995 for incoming, 587 or 465 for outgoing
bump up the Server Timeouts slider to the high end
WitteGeek402
 
Posts: 36
Joined: Sun Jun 09, 2013 11:46 am
HydroFLASH Type: HydroFLASH Wired Version
Mobile App Type: Android
Insteon Devices: Yes

Re: test email

Postby Support » Fri Aug 02, 2013 10:32 pm

Hi,

Several owners have had issues with Comcast's smtp server. We are looking into why but in the mean time here is a simple solution. Long term we are looking at integrating the smtp service into the HydroFLASH cloud service as a possibility. This would simplify setup and operation.

Here is an optional solution for outgoing mail from hydroflash:

This is a free service (allows 10 sent emails per day) and it works OK. HydroFLASH will send 1 to 3 max unless your log file is filling up with errors.
http://www.mysendmail.com/

Whatever email address you use to sign up will need to also be in the "From" box on the HF settings page. Here is an example:

image.png
image.png (15.15 KiB) Viewed 15124 times
Brooks
HydroFLASH Support
Support
 
Posts: 319
Joined: Sat Mar 02, 2013 4:46 pm
HydroFLASH Type: HydroFLASH WiFi Version
Mobile App Type: Both
Insteon Devices: Yes

Re: test email

Postby ExploreUtah » Sat Aug 03, 2013 1:17 am

WitteGeek402, yes I did key in the password. I read the SSL/TSL issue and believe it must be that. Thanks

Support, thanks for the alternative email provider option. However, between work and home, I have too many email accounts to manage from multiple ISP's. Adding one more from another service might cause some (un)expected Operator memory errors that I can live without for now. I'll go without the email option until you guys make some enhancements. If you figure out the Comcast SMTP issues, please post the solution. Thanks for your help.
ExploreUtah
 
Posts: 2
Joined: Tue Jul 30, 2013 1:23 am
HydroFLASH Type: ----
Mobile App Type: ----
Insteon Devices: ----

Re: test email

Postby Support » Sat Aug 03, 2013 2:21 am

Hi,

I understand completely. Here is what we know about comcast smtp.

Connecting to smtp.comcast.net on port 587 takes a long time for some reason to present the standard id message. Something like 5 to 7 seconds as compared to others like cox which are instantaneous for the most part.

Follow this with the standard EHLO and the resulting response indicates that they support PLAIN and LOGIN. HydroFLASh supports these no problem. The authentication methods supported are listed in bold. Examining the timing relationship in HydroFLASH we may have given up on the server response due to the lengthy delay. We are looking into this as a possible cause. Some servers require the Log in email address to be in the FROM email address also (like yahoo) Yahoo works fine for LOGIN and send fine along with COX, RoadRunner and others. Perhaps you can use on of your other ISP's smtp servers for now? As I stated before we are looking at the possibility to make it easier and set up a smtp server on the cloud that would only allow email to be sent from HydroFLASH. I'll update this thread as we know more or find a solution to the issue.

This is ComCast
220 omta14.emeryville.ca.mail.comcast.net comcast ESMTP server ready
EHLO me@hydroflash.net
250-omta14.emeryville.ca.mail.comcast.net hello [XX.XX.XX.XX], pleased to meet you
250-HELP
250-AUTH LOGIN PLAIN
250-SIZE 36700160
250-ENHANCEDSTATUSCODES
250-8BITMIME
250-STARTTLS
250 OK

Here is COX
220 fed1rmimpo306 cox ESMTP server ready
EHLO me@hydroflash.net
250-fed1rmimpo306 hello [XX.XX.XX.XX], pleased to meet you
250-HELP
250-AUTH LOGIN PLAIN CRAM-MD5
250-SIZE 28672000
250-ENHANCEDSTATUSCODES
250-8BITMIME
250-STARTTLS
250 OK

Here is Yahoo
220 *.smtp.mail.yahoo.com ESMTP ready
EHLO me@hydroflash.net
250-*.smtp.mail.yahoo.com
250-PIPELINING
250-SIZE 41697280
250-8 BITMIME
250-AUTH PLAIN LOGIN XYMCOOKIE
250 STARTTLS
Brooks
HydroFLASH Support
Support
 
Posts: 319
Joined: Sat Mar 02, 2013 4:46 pm
HydroFLASH Type: HydroFLASH WiFi Version
Mobile App Type: Both
Insteon Devices: Yes

Re: test email

Postby Noircogi » Tue Sep 17, 2013 9:01 pm

Any update on allowing SSH connction for sendmail? I use that with my home server and Gmail's free service.
Noircogi
 
Posts: 6
Joined: Thu Jun 27, 2013 3:37 am
HydroFLASH Type: ----
Mobile App Type: ----
Insteon Devices: ----

Re: test email

Postby bobcaspe » Fri May 09, 2014 2:45 am

I am using Verizon.net and I have yet to see a test email work successfully. As I screw around with different configurations of settings, sometimes I get an error and sometimes nothing, but never do I actually receive an email at my server? Here's some of the log..

Thu 05-08-2014 22:20:03 - Set up Local Time Zone Offset
Thu 05-08-2014 22:20:27 - Set up Local Time Zone Offset
Thu 05-08-2014 22:20:46 - Set up Local Time Zone Offset
Thu 05-08-2014 22:20:54 - ERROR: MCGetSmtpAuthentication fails and returns -4.
Thu 05-08-2014 22:20:54 - Log File Sent - Email task completed successfully.
Thu 05-08-2014 22:21:07 - Set up Local Time Zone Offset
Thu 05-08-2014 22:21:38 - ERROR: MCGetSmtpAuthentication fails and returns -4.
Thu 05-08-2014 22:21:38 - Log File Sent - Email task completed successfully.
Thu 05-08-2014 22:21:42 - Set up Local Time Zone Offset
Thu 05-08-2014 22:22:40 - Set up Local Time Zone Offset
Thu 05-08-2014 22:23:07 - Set up Local Time Zone Offset
Thu 05-08-2014 22:23:41 - Set up Local Time Zone Offset
Thu 05-08-2014 22:24:06 - Set up Local Time Zone Offset
Thu 05-08-2014 22:24:50 - Set up Local Time Zone Offset
Thu 05-08-2014 22:24:57 - ERROR: MCGetSmtpAuthentication fails and returns -4.
Thu 05-08-2014 22:24:57 - Log File Sent - Email task completed successfully.
Thu 05-08-2014 22:30:00 - Set up Local Time Zone Offset
Thu 05-08-2014 22:33:16 - ERROR: MCGetSmtpAuthentication fails and returns -4.
Thu 05-08-2014 22:33:16 - Log File Sent - Email task completed successfully.
Thu 05-08-2014 22:40:45 - Set up Local Time Zone Offset
Thu 05-08-2014 22:41:49 - Set up Local Time Zone Offset
Thu 05-08-2014 22:42:53 - Set up Local Time Zone Offset

I just don't get what I'm doing wrong. I do believe that Verizon does require SSL?
bobcaspe
 
Posts: 1
Joined: Thu Sep 12, 2013 8:13 pm
HydroFLASH Type: ----
Mobile App Type: ----
Insteon Devices: ----

Next

Return to Feature Requests

Who is online

Users browsing this forum: No registered users and 1 guest

cron